Download DataLink Connect for Mac

MacBook? No problem. We've got you covered.

You’re about to take the next step with K-12 analysis and reporting. Just complete the form to automatically download your DataLink Connect Software!

OS Requirements

  • Mac minimum requirements for installing DataLink Connect – Macintosh- OSX 10.4 or higher
  • PC user? Click Here